Migrating ONST-01 To ProxMox
Resolved
May 25 at 08:02pm CDT
okay, I was right. After some fiddling around with static IPs, I got it working and the node is working again.
I'll take some time to ensure that it's working properly before we conclude the maintenance period.
Affected services
Chicago_IL-01
Updated
May 25 at 07:30pm CDT
I swear it's problem after problem. But thankfully I'm like 80% what the problem is now.
I got the VM transferred to ProxMox, but it isn't connecting to the internet. I'm gonna see if it's an issue with the IP it's requesting.
Affected services
Chicago_IL-01
Updated
May 25 at 02:13pm CDT
Data is now being imported onto a ProxMox VM, and should be uploaded soon.
Affected services
Chicago_IL-01
Updated
May 25 at 01:25pm CDT
Okay, after like 4 hours of networking and wanting to die, I went to sleep. I woke up and got it all fixed, now we can begin importing your data into ProxMox.
Affected services
Chicago_IL-01
Updated
May 25 at 02:44am CDT
We got the server moved over to our workstation and hooked up a monitor with a K&M. ProxMox finished flashing so we're gonna start the installation process.
Affected services
Chicago_IL-01
Updated
May 25 at 02:32am CDT
ProxMox is now being flashed. We will turn off the node server and physically load it into our workstation to get it all installed.
Affected services
Chicago_IL-01
Updated
May 25 at 02:30am CDT
A clone of a backup has been made and converted to QCOW2. We are now downloading a ProxMox VE iso to flash onto the flashdrive.
Affected services
Chicago_IL-01
Updated
May 25 at 02:19am CDT
We've backed up the data onto the backup thumb drive and the PC, pending transfer to Proton Drive, which will then be transferred to Google Drive and our Private File Hosting service after everything is done.
Due to time constraints, we'll continue with cloning a backup to convert it to QCOW2 and continuing from there.
Affected services
Chicago_IL-01
Created
May 24 at 11:00pm CDT
We’re preparing to migrate our ONST-01 (Chicago_IL-01) node from its current Windows Server environment to Proxmox!
This upgrade has been a long time coming, but originally we didn't have a flash drive on hand to install Linux or Proxmox (actually 😭), but now we're all set and ready to move forward.
🔧 What’s Happening:
- Current OS: Windows Server
- New Environment: Proxmox VE
- Reason: Improved stability, performance, and ease of management
📅 Migration Plan:
- Back up VHDX (Your server files) to 4 locations:
Google Drive
Another Flash Drive
Another PC
Our Private File Host
.- Verify all backups to ensure they’re complete and not corrupted
- Take one of the backups, back it up, and convert the back up into the QCOW2 format (for proxmox)
- Flash ProxMox onto the dedicated flashdrive
- Perform Proxmox installation and post-setup configuration
- Restore services and user data
- Test and verify everything’s running smoothly
📢 Communication:
We’ll provide real-time updates here as we go, so you’ll always know the status of your data and services.
Affected services
Chicago_IL-01